Home Forums Themes Support Gecko "Available on backorder" is shown to late

Topic Resolution: Resolved

This topic contains 13 replies, has 2 voices, and was last updated by  Harry 6 months, 1 week ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #17905

    stock of product is 0 or lower and setting is that customer can order with information.

    But:
    the info “Available on backorder” will first shown in shoping cart, but not in product description in shop.

    Shouldnt already in shop/product description be shown “Available on backorder” instead of “in stock”?

    #17931

    Hi Adam,

    Please edit product and follow this screenshot http://take.ms/js0evV

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #17952

    Hi Adam,

    Please ask plugin author for solution, i know only default feature.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #17961

    I deactivated the plugin and the problem seems to be within theme/woocommerce.

    #17982

    Hi,

    I now checked plugin etc. and also changed to twenty seventeen Theme.
    With theme change I saw that it works correct, so it has to be with Gecko theme why in product page “in stock” is shown instead of “Available on backorder”.

    Can you please check it from your side.

     

    thanks

    Adam

    #17987

    Hi,

    I fixed the issue on your site, please check.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18080

    Something is still wrong as it will not be shown in german. But it’s translated in locotrans

    #18086

    Hi,

    Please go to Loco Translate > Theme > Gecko and click on Sync button to update string and try translate again.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18093
    This reply has been marked as private.
    #18110

    Hi Adam,

    I recommend save translated file in system http://take.ms/1wh2K

    If still doesn’t work please try search string in plugin.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18121

    I changed theme to twenty and it works.
    The translations are correct in this file for gecko: gecko-de_DE_formal.po
    because I can see that the correct translation for “available on backorder” works.

    Also I can say that since your manual fixing to make the backorder translation works the “in stock” is shown only in english.

    So I assume since your last change it doesnt take anymore the translation which i did before.

    #18143

    Hi Adam,

    I saw you add 2 language file German and German (Formal). Could you try delete one file, maybe this cause conflict.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18157

    i did, but it doesnt help.

    as already said: before you “fixed” something at the theme setting to make the “backorder” information work it was correct shown the translation

    #18178

    Hi Adam,

    I forgot update string in Loco Translate > Themes > Gecko > Edit language > Sync.

    It now ok.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.