Home Forums Themes Support Claue Extra Loding

Topic Resolution: Resolved

This topic contains 12 replies, has 2 voices, and was last updated by  Harry 2 months, 1 week ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #29686

    Hi Harry,

    I realized in the pages that have products slider, we have extra loading time in mobile.

    I had some products slider in the homepage that was causing extra time for loading.

    I disabled the slider and it’s fixed now.

    But for the products pages, we have related products in the button, which cannot be slider in desktop but but it’s slider for sure in the mobile according to the numbers in the theme dashboard.

    I checked this on your demo too and found this is happening there too.

    Please recreate the issue with real mobile not mobile view of the browser.

    I found the slider on your site only in the related products of the products pages.

    Regards

    Rahim Vaziri
    CEO & Founder at Look.ir

    #29687

    And this happening much more in Chrome.

    Regards

    Rahim Vaziri
    CEO & Founder at Look.ir

    #29688

    Hi Rahim,

    Which version of Chrome on your site?

    I check your site or our demo on Chrome it still work well. Please try check on other computer with Chrome.

    Kind regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #29689

    Hi Harry,

    I am using the latest chrome version on mobile and computer.

    It’s not about checking on computer, you should check it on your mobile.

    And just check the pages that have visual composer products slide.

    Like the related products of this product on your own site:

    http://janstudio.net/claue/demo/product/cyan-boheme/

    Open this link with your mobile.

    And you will see an extra loading time of browser while loading th related products.

    I have checked this with three friends of mine and same happend.

    This is coming after the update.

    Please scroll the page with your finger when you are in the link above.

    Rahim Vaziri
    CEO & Founder at Look.ir

    #29710

    Hi Harry,

    Hope you are fine.

    Were you successful to retrace the issue that I said?

    Regards

    Rahim Vaziri
    CEO & Founder at Look.ir

    #29711

    Hi Rahim,

    I check on Chrome on my computer and 2 iPhone iOS 10 and iOS 12 it still work normal.

    Kind regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #29713

    Hi Harry,

    If you don’t see the issue I think we are misunderstanding that but It’s fine. 🙂

    As I said this issue happens where we have the products slider of WP Bakery in the page.

    It’s not causing on your homepage because you don’t have any slider in that.

    And It will not happen in the product pages in the desktop because of the width of display that shows all of related products in a row but in the mobile because of the width it switches to the slider and two products per slide, extra loading time for page and white bank page happens for maybe 1.5 seconds somewhere between title of the product and related products.

    As a choice, I have disabled all the sliders I had on my site but right now I don’t have any option for related product on mobile, it switches to slider automatically.

    Can I disable the slider of related products and have them as a normal grid?

    I have 6 related products, I like to have 3 rows of two products next together.

    Right now the related products are disabled via a function on my site till finding the solution for this.

    /* hiding related products */
    remove_action( 'woocommerce_after_single_product_summary', 'woocommerce_output_related_products', 20 );

    Thank you.

    Rahim Vaziri
    CEO & Founder at Look.ir

    #29714

    Hi Rahim,

    Please copy file related.php from claue > core > libraries > vendors > woocommerce > templates > single-product to claue-child > woocommerce > single-product

    and change code online 30 from

    <div class="jas-carousel" data-slick='{"slidesToShow": <?php echo (int) $limit; ?>,"slidesToScroll": 1,"responsive":[{"breakpoint": 1024,"settings":{"slidesToShow": 3}},{"breakpoint": 480,"settings":{"slidesToShow": 2}}]<?php echo ( is_rtl() ? ',"rtl":true' : '' ); ?>}'>

    to

    <div class="jas-products">

    Kind regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #29717
    #29718

    Hi Rahim,

    Sorry, please change

    <div class="jas-products">

    to

    <div class="jas-row">

    Regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #29719

    Thank you so much Harry,

    It’s working fine now.

    But in mobile it needs a small CSS fix: http://prntscr.com/mz0z1u

    I will appreciate your help.

    Rahim Vaziri
    CEO & Founder at Look.ir

    #29720

    Product: https://look.ir/uRLec

    Rahim Vaziri
    CEO & Founder at Look.ir

    #29723

    Hi Rahim,

    Please add below code to Claue > Theme Option > General Layout > Custom CSS

    @media only screen and (max-width: 736px) {
    .product-extra .jas-row {padding: 0 15px}
    }

    Regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.