Your account expired support, please renew to get your support.

Home Forums Themes Support HelpDesk Issues Configuring HelpDesk theme

Topic Resolution: Resolved
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #34260
    murphyk8
    Support Expired

    Hi there,

    I ran into a few issues when trying to update the way the theme displays:

    Number 1

    Related to previous topic where I closed the request out too early – http://support.janstudio.net/forums/topic/remove-my-account-from-the-header/.

    I want to remove the ‘My Account’ button from the header section. The previously suggested solution of adding CSS is not suitable:

    .jas-account-menu {
    display: none;
    }

    That hides the button visually and was fine until I added a menu. The button still takes up space in the layout causing header menu to position badly. So I need a better solution for this.

     

    Number 2

    In the default footer ‘Follow Us’ widget there are a number of icons used utilising Font Awesome for the relevant social media links. I want to add a link to our blog but when I try to use the Font Awesome icon for a blog it doesn’t seem to work correctly:

    <i class=”fas fa-blog”></i>

    How can I add a relevant icon for a link to our blog?

     

    Number 3

    The default page headers for all sections use the background image ‘/assets/images/page-head-bg.jpg’ and I am trying to change that to use a background colour instead.

    I have found settings in JanStudio > Theme Options that seem to be designed to set this but there is no image assigned in the setting and when select a colour using the colour picker nothing changes. What do I need to do to remove the default image and replace it with a colour?

     

    Number 4

    There doesn’t seem to be a widget to include the Knowledgebase categories in the sidebar. There is an option to include the standard blog categories. Is there a way to include the Knowledgebase Categories that I have missed?

     

    Number 5

    The Knowledge Base category pages don’t seem to be getting generated correctly. The categories exist but if you use the relevant links they return 404 errors.

     

     

    #34261

    Hi Murphy,

    1. Please download attach file, extract and put in helpdesk-child

    2. Our theme use version 4.7 of fontawesome https://fontawesome.com/v4.7.0/icons/ so please change class to

    3. Please go to JanStudio > Theme Options and change or remove background image of Page Title Backgournd for separate Knowledge, forum, faq,.. etc

    4. Please use widget Helpdesk-KnowledgeBase

    5. Please go to JanStudio > Theme Options > KnowledgeBase update slug and after that go to Settings > Permalinks > Save

    Kind regards

    Attachments:
    You must be logged in to view attached files.

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #34263
    murphyk8
    Support Expired

    Hi Harry,

    Thank you for the follow up.

    1. That seems to have done the trick, thank you.
    2. Ok, thank you for the update. The icon I was planning to use is not available in that version but I can use another.
    3. In the ‘Page Title Backgournd’ settings for each of the areas the file selector is blank already (image attached) but it still uses the image instead of the colour.
    4. Helpdesk-KnowledgeBase gives a list of articles, not categories. What I would like is something similar to the standard Categories widget with a DDL to select the relevant category.
    5. That has worked, thank you.
    Attachments:
    You must be logged in to view attached files.
    #34266

    Hi Murphy,

    3. Please add below code to JanStudio > Theme Option > General Layout > Custom CSS

    .page-head {
    	background-image: inherit;
    }

    4. I’m sorry it doesn’t option to select knowledgebase category as dropdown, it only have option to show list of articles.

    Kind regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #34277
    murphyk8
    Support Expired

    3. Thank you, that does remove the background image but leaves the background as grey. Changing the colour in the settings doesn’t seem to work at all.

    I also tried adding further custom CSS to update the colour (to the same colour I have selected in the UI). While that does affect the colour for some reason that results in a different colour showing than the one added in the CSS:

    .page-head {
    background-image: inherit;
    background-color: #1e73be !important;
    padding: 50px 0;
    }

    But the resulting colour on the page is #081D30 (image attached)

     

    4. That is a pity, but thank you for confirming.

     

     

    Attachments:
    You must be logged in to view attached files.
    #34283

    Hi Murphy,

    please add more code

    .page-head::before {
    	background: none;
    }

    Kind regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #34285
    murphyk8
    Support Expired

    Hi Harry,

    That seems to have fixed it, thank you.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.