Home Forums General Forum WooCommerce Product Bundles don’t work

Viewing 1 reply thread
  • Author
    Posts
    • #38713
      marinalogu
      Supported

      apparently there is an incompatibility between the theme and the plugin. They comment that the problem comes from the ajax add to cart button. Please I need help inmediately.

      the bundle product example: https://miradorioshop.es/product/pack-miradorio/

      I copy the answer by plugin support.

      ….

      Hi there,

      Thank you for your reply!

      I definitely understand that investigating plugin conflicts is not ideal and can be time-consuming!

      Taking a look at this product: https://miradorioshop.es/product/pack-miradorio/, its configuration seems correct! However, I noticed that you theme is using custom, AJAX-enabled add-to-cart buttons in single product pages. By default, WooCommerce supports AJAX functionality only for Add to Cart buttons in Shop Archives. Making AJAX-enabled add-to-cart buttons work correctly in single-product pages requires a bit more work — right now, your theme is failing to post all form contents when the add-to-cart button is clicked. This issue is not limited to Product Bundles and will affect any other plugins that add custom fields to product pages!

      If you’d like, you can confirm this by temporarily switching your active theme back to a default WordPress theme, such as Twenty Seventeen or the WooCommerce compliant Storefront theme on a staging site. Once you do this, add-to-cart buttons should work without issues.

      The best way to proceed is to bring this to the attention of your theme authors. Keep in mind that most theme authors who advertize WooCommerce support are committed to fixing compatibility issues like this one — however, the only way to find out is by reaching out to them. There is also a chance that they can disable AJAX Add to Cart buttons on specific pages.

      Let us know how it goes!

      Cheers,

       

      Attachments:
      You must be logged in to view attached files.
    • #38717
      Harry
      Supported

      Hi Marinalogu,

      Please go to WooCommerce > Settings > Products > Add to cart behavior and uncheck 2 last fields to disable Ajax Add to Cart.

      Kind regards

      Harry
      Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

Viewing 1 reply thread

You must be logged in to reply to this topic.