Home Forums Themes Support Gecko Yith popup issue 'Ops! Something went wrong'

This topic contains 4 replies, has 2 voices, and was last updated by  Harry 5 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #15827

    Hello,

    Ive been searching around for a solution for this and I have tried your https://kb.mc4wp.com/fix-the-oops-something-went-wrong-error/ but it did not work for me:

    What im seeing:

    • when logged into wp I am able to subscribe via the yith newsletter popup
    • when not logged in (incognito window for test) I am not able to subscribe using the popup and I see the ‘Ops! Something went wrong’

     

    This is what the 200 request looks like when logged into wp:
    jquery.js?ver=1.12.4:2 XHR finished loading: GET
    “https://**.com/wp-admin/admin-ajax.php?yit_mailchimp_newsletter_form_email=patrick%40gmail.com&yit_mailchimp_newsletter_form_id=4280&action=ypop_subscribe_mailchimp_user&yit_mailchimp_newsletter_form_nonce=ca65e0cab0&_wp_http_referer=%2F&_=1515273274053”.

     

    When not logged in I see the error 400:

    jquery.js?ver=1.12.4:2 GET
    https://**.com/wp-admin/admin-ajax.php?yit_mailchimp_newsletter_form_email=patrick%40gmail.com&yit_mailchimp_newsletter_form_id=4280&action=ypop_subscribe_mailchimp_user&yit_mailchimp_newsletter_form_nonce=2e61103d88&_wp_http_referer=%2F&_=1515273908072 400 (Bad Request)

     

    Please let me know what else to check.. It’s still not working

    #15828

    Hi Patrick,

    Please follow this topic https://wordpress.org/support/topic/messaggio-0-nella-sottoscrizione/

    In file
    yith-woocommerce-popup/includes/newsletter-integration/Mailchimp.php
    change line 77

    add_action( 'wp_ajax_ypop_nopriv_subscribe_mailchimp_user', array( $this, 'subscribe_mailchimp_user'));

    to

    add_action( 'wp_ajax_nopriv_ypop_subscribe_mailchimp_user', array( $this, 'subscribe_mailchimp_user'));

    Best regards

    #15916

    Hi Harry

    Thanks for the response,

    I have modified line 77 in yith-woocommerce-popup/includes/newsletter-integration/Mailchimp.php to: add_action( ‘wp_ajax_nopriv_ypop_subscribe_mailchimp_user’, array( $this, ‘subscribe_mailchimp_user’));

     

    I am now getting a new error “Something went wrong: Mailchimp list related error (basic action)”
    I can see the above error when logged in to wpdashboard and also when not logged in.

    Browser test (logged out of wp):

    • Console log outgoing transmission to mailchimp: jquery.js?ver=1.12.4:2 XHR finished loading: GET “https://***.com/wp-admin/admin-ajax.php?yit_mailchimp_newsletter_form_email=patrick%40***.ca&yit_mailchimp_newsletter_form_id=4280&action=ypop_subscribe_mailchimp_user&yit_mailchimp_newsletter_form_nonce=ecfdd9800d&_wp_http_referer=%2Ftest%2F&_=1515585241357”.
    • Mailchimp log:
      date/time: 2018-01-10 11:52:12 GMT
      result: green checkmark
      throttled?: nope
      source ip: 104.***.***.203
      method: lists/batch-subscribe
      format: json
      exec time: 0.048s
      useragent: MailChimp-PHP/2.0.4
      ver: 2.0
      response: n/a
    • cleared frontend cache
    • restarted apache2 service just to make sure

    Any tips?

     

     

     

     

     

     

     

    #15917

    Ah!

    looks like the email I have been testing with may have been overused, I tried 3 more unique emails that I have not tested and they do subscribe successfully

    Thanks for all the help here!

    ~PM

    #15923

    Hi PM,

    Did you issue solve? Please let me know.

    Thanks

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.