Home Forums Themes Support Claue Variation Product

This topic contains 16 replies, has 2 voices, and was last updated by  Harry 8 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #18035

    Hi Harry,

    I got confused about something strange in the website that I cannot solve it.

    The problem is about the products of the Shoes category which have variations with color and size!

    Whenever I add a shoe which has different color and size to the cart, it is shown different from the normal state , and this only happens for the shoes! I have different categories for shoes. I mean Men’s Shoes and Women’s shoes…

    And this doesn’t happen for only the size, the shoe should has color and size at the same time!

    The cart pop up and the and the cart page shows that differently!

    In the attached image, both products have variations with size and color.

    The second one is shown correctly but the first one which is a shoe, has the words of color and size in the cart pop up and cart page!

    How can I fix this?

    Attachments:
    You must be logged in to view attached files.

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18038

    And Harry,

    The RTL pagination has not been fixed as you mentioned in your change log of the update!

    I reverted the translation of the words of Next & Prev to see better what I mean in Here!

    The arrows in Here has been fixed by rotation transform css in products listing , but as you see this rotation has made the words of Next & Prev broken in the Blog.

    How can I fix this?

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18052

    Hi Rahim,

    1. Could you explain more about the issue with Variable product?

    2. I fix issue with pagination on your site.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18064

    Hi Harry,

    Sorry. I mean Variable Products.

    Well actually the variable products doesn’t have any issue by default.

    But as you know when you add a variable product to the cart, in the cart pop up or in the cart page, in the row of that product that you have added , you have the product title and then with a ” – ” the values of the attributes come.

    Like this Shoes : Adidas Performance(Title of the Product) – Black(The value of the color), 42(The value of the size)

    In my website all variable products are fine, but whenever I add a shoe with variable with size and color, it is shown differently in the cart pop up!

    As you see above! I didn’t find the solution for this!

    In the first attachment ( Capture 1 ) you see what I mean.

    After the title , instead of coming the value of the color and size by ” – ”

    it is like this :

    Adidas Performance(Title of the Product)

    Color:                                                    Gray

    Size :                                                        42

    And this happens only for the shoes with two variation at a same time!

    In the first attachment ( Capture 1 ) , you see two products that have variation with color and size.

    But the shoes and only the shoes are shown differently.

    However I am using one attribute for color and one for size.

    But only for shoes it’s shown differently!

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18065

    In here I share you the link of two variable products.

    You add them to your cart.

    And you will find out what I mean.

    Consider about the showing of the shoes which is not normal but the other one is normal.

    I should say both of them have the same variation about the size and color!

    Shoes : https://look.ir/c6Fx

    Clothes : https://look.ir/VvdQ

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18067

    Here it is

    Attachments:
    You must be logged in to view attached files.

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18084

    Hi Rahim,

    I try on my local when i switch to default theme StoreFront it have same issue
    http://take.ms/KmOMm

    I think it not critical issue.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18088

    Hi Harry.

    I wonder why this happens only for the shoes!!!

    Whenever I add another product with exactly same attributes like color and size, they are shown normally, but only for shoes this happens!

    I will make a topic in Woocommerce for this, and if they answered I will share that with you.

    Thank your for trying to help me. 🙂

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18095

    Thanks Rahim,

    Let me know when you have feedback from WooCommerce team.

    Have a nice day!

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18188

    Hi Harry,

    Hope you and my other friends are fine. 🙂

    Harry, I worked about one hour on this and found out where it comes from.

    First of all as you know this comes from the variable products with different attributes for color and shoes size.

    So I made two test attributes for color and shoes size and entered some same samples as values for them.

    And edited that product which had the issue with these test attributes and saw that ” They are showing normally as I want ”

    So I found out that the problem comes from the attributes not the category or the product, because I have many shoes category like Mens, Women, Kids and o course it’s not about the product.

    So I changed the test color attribute with the main color attribute, and saw that it is still showing normally.

    Then changed the test shoes size attribute with main one and saw that the issue happened again!!!

    So the issue comes from shoes size attribute!

    Finally after working on this attribute I found out that the issue comes from the slug of this attribute which is ” shoes-size ”

    I changed it to for example ” shoes ” and saw the problem is solved!

    How could this happen?!

    I haven’t shared this with Woocommerce yet. You can check it on your end.

    Can we find where it comes from?

    Well actually the best slug for this attribute is that ” shoes-size ” but changing this to something else can help!

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18189

    Here are the products that had problem before :

    p1 : https://look.ir/dL5a

    p2 : https://look.ir/c6Fx

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18214

    Hi Rahim,

    I’m not sure this issue because i check default theme with same issue this come from plugin so we need woocommerce team fix bug.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18233

    Hi Harry,

    I understand that it’s so strange and unusual.

    But as I said only the shoes have this problem and I fixed that with changing the slug of the attribute!

    Your theme shows the values of the variable products after a – and separated with a ,

    I only had the problem with shoes cause I have added many variable products with plenty of attributes!

    Still don’t have any idea how can this happen!

    The attachments are the results for a shoes at the same size and color before and after changing the slug.

    Attachments:
    You must be logged in to view attached files.

    Rahim Vaziri
    CEO & Founder at Look.ir

    #18253

    Hi Rahim,

    Could you try create a test variable with slug contain “-” i think the issue have with slug.

    Best regards

    Harry
    Premium Wordpress themes and plugins, Best WooCommerce theme https://themeforest.net/user/janstudio/portfolio?ref=janstudio

    #18263

    Hi Harry,

    Yeah. You are right.

    Just tested that.

    As you said this happens when a variable product has a variation which comes from an attribute which has – in its slug.

    Hopefully the ” _ ” works fine! So this could be a solution for separation in the slug.

    But I also checked that even a variable product has many attributes with or without ” – ” , if you check only 1 attribute ” Used for variations ” which has ” – ” , as a variation , it is still normal , but when the variations number that comes from other attributes goes more than 1 ,  it will be broken!

    Rahim Vaziri
    CEO & Founder at Look.ir

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.